summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorBrian Picciano <me@mediocregopher.com>2024-07-19 15:24:03 +0200
committerBrian Picciano <me@mediocregopher.com>2024-07-19 15:24:03 +0200
commitdd47b35a43d4f49716112391b49f00a78702c459 (patch)
tree70b47e84ef32a7462142c25a488e031d0778d284 /default.nix
parentdf6e00d2c4096b0de282bd1b2e0f93f1b69ebfe6 (diff)
Revert "Use difftastic for git diffing"
This reverts commit 895aa07eea96f718f57aa3157c51b0a4c3ef32d4.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix13
1 files changed, 1 insertions, 12 deletions
diff --git a/default.nix b/default.nix
index 921d775..9da4a9f 100644
--- a/default.nix
+++ b/default.nix
@@ -44,17 +44,7 @@ in rec {
gitWrapped = pkgs.writeShellScript "git" ''
export XDG_CONFIG_HOME=${gitConfig}
- bin="${pkgs.git}/bin/git"
-
- # Overwrite show an log sub-commands to always set --ext-diff. git aliases
- # don't allow for overwritting sub-commands, or I'd use them instead.
- if [ "$1" = "show" ] || [ "$1" = "log" ]; then
- subCmd="$1"
- shift
- exec "$bin" "$subCmd" --ext-diff "$@"
- fi
-
- exec "$bin" "$@"
+ exec ${pkgs.git}/bin/git "$@"
'';
git = pkgs.runCommand "mediocregopher-git" {} ''
@@ -93,7 +83,6 @@ in rec {
pkgs.less
pkgs.tmux
pkgs.calc
- pkgs.difftastic
pkgs.units
pkgs.man