summaryrefslogtreecommitdiff
path: root/nix/nixgl.nix
diff options
context:
space:
mode:
authorBrian Picciano <me@mediocregopher.com>2024-06-17 12:43:47 +0200
committerBrian Picciano <me@mediocregopher.com>2024-06-17 12:43:47 +0200
commit698b92d7fb26680ebb0328c5c6c985071ff79a0a (patch)
treeb51e7b3dff0053503a2b6bdad789f3a17a07f969 /nix/nixgl.nix
parent4576644b8f37f71fe82c51e95d1dc06615ef5f14 (diff)
Fix X server not picking up system library files
Diffstat (limited to 'nix/nixgl.nix')
-rw-r--r--nix/nixgl.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/nix/nixgl.nix b/nix/nixgl.nix
new file mode 100644
index 0000000..82dbdfd
--- /dev/null
+++ b/nix/nixgl.nix
@@ -0,0 +1,14 @@
+pkgs: let
+
+ src = builtins.fetchTarball {
+ name = "nixgl-unstable";
+ url = "https://github.com/guibou/nixGL/archive/7165ffbccbd2cf4379b6cd6d2edd1620a427e5ae.tar.gz";
+ sha256 = "1wc85xqnq2wb008y9acb29jbfkc242m9697g2b8j6q3yqmfhrks1";
+ };
+
+ nixgl = (import src) {
+ inherit pkgs;
+ enable32bits = false;
+ };
+
+in nixgl.auto.nixGLDefault