summaryrefslogtreecommitdiff
path: root/pkgs.nix
diff options
context:
space:
mode:
authormediocregopher <mediocregopher@gmail.com>2023-08-13 21:34:14 +0200
committermediocregopher <mediocregopher@gmail.com>2023-08-13 21:35:17 +0200
commit1957081c122fe231eb6120192489dd979d214317 (patch)
treeb8cd0812ec3c0452d54cb789ba938e6f0c0e8278 /pkgs.nix
parentef8da74f1ae38d9eceb68846fe9ef402c8e30fcf (diff)
Update branch with all changes which could be brought in from private branches
For a while I was keeping a private branch where there were a lot of non-public things included, and that became the de-facto branch while this one lagged. This one is now up-to-date, all private stuff is dealt with via config files which are not committed.
Diffstat (limited to 'pkgs.nix')
-rw-r--r--pkgs.nix69
1 files changed, 39 insertions, 30 deletions
diff --git a/pkgs.nix b/pkgs.nix
index c79130d..527968d 100644
--- a/pkgs.nix
+++ b/pkgs.nix
@@ -1,41 +1,50 @@
-let
+rec {
- src = builtins.fetchTarball {
- name = "nixpkgs-2105";
- url = "https://github.com/nixos/nixpkgs/archive/7e9b0dff974c89e070da1ad85713ff3c20b0ca97.tar.gz";
- sha256 = "1ckzhh24mgz6jd1xhfgx0i9mijk6xjqxwsshnvq789xsavrmsc36";
- };
+ mkPkgs = src: let
- normalPkgs = (import src) {};
+ normalPkgs = (import src) {};
- config = {
- allowUnfree = true;
- packageOverrides = pkgs: {
-
- go = builtins.fetchTarball {
- url = "https://golang.org/dl/go1.17.1.linux-amd64.tar.gz";
- sha256 = "1196h1jx9cn5ks1y9r95z0q2s6m6ssvnx7jd34g435jvxjgb2c94";
- };
+ config = {
+ allowUnfree = true;
+ packageOverrides = pkgs: {
- nixgl = let
+ nixgl = let
- src = builtins.fetchTarball {
- name = "nixgl-unstable";
- url = "https://github.com/guibou/nixGL/archive/51f19871a31b15b482ac4c80976da173289e77fb.tar.gz";
- sha256 = "0dj2apbx5iqvkiixyz1dzx4id51iw9s2isp1f9x60a03f5sqcvvi";
- };
+ src = builtins.fetchTarball {
+ name = "nixgl-unstable";
+ url = "https://github.com/guibou/nixGL/archive/7165ffbccbd2cf4379b6cd6d2edd1620a427e5ae.tar.gz";
+ sha256 = "1wc85xqnq2wb008y9acb29jbfkc242m9697g2b8j6q3yqmfhrks1";
+ };
- nixgl = (import src) {
- inherit pkgs;
- enable32bits = false;
- };
+ nixgl = (import src) {
+ inherit pkgs;
+ enable32bits = false;
+ };
- in nixgl.nixGLIntel;
+ in nixgl.auto.nixGLDefault;
+ };
};
- };
-in pkgsArg:
- (import src) (
+ in pkgsArg: (import src) (
normalPkgs.lib.attrsets.recursiveUpdate { config = config; } pkgsArg
- )
+ );
+
+ stable = mkPkgs (builtins.fetchTarball {
+ name = "nixpkgs-2105";
+ url = "https://github.com/nixos/nixpkgs/archive/7e9b0dff974c89e070da1ad85713ff3c20b0ca97.tar.gz";
+ sha256 = "1ckzhh24mgz6jd1xhfgx0i9mijk6xjqxwsshnvq789xsavrmsc36";
+ });
+
+ stable2305 = mkPkgs (builtins.fetchTarball {
+ name = "nixpkgs-2305";
+ url = "https://github.com/nixos/nixpkgs/archive/4ecab3273592f27479a583fb6d975d4aba3486fe.tar.gz";
+ sha256 = "sha256:10wn0l08j9lgqcw8177nh2ljrnxdrpri7bp0g7nvrsn9rkawvlbf";
+ });
+
+ edge = mkPkgs (builtins.fetchTarball {
+ name = "nixpkgs-edge";
+ url = "https://github.com/nixos/nixpkgs/archive/f9418c4c7fab906c52ae07cf27a618de7722d1e9.tar.gz";
+ sha256 = "sha256:067m1gzj1n06m3anshwgabd1liaja8gcvd90spmnyi3a6vhqdvq0";
+ });
+}