summaryrefslogtreecommitdiff
path: root/awesome/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'awesome/default.nix')
-rw-r--r--awesome/default.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/awesome/default.nix b/awesome/default.nix
index acc6375..bc2b34b 100644
--- a/awesome/default.nix
+++ b/awesome/default.nix
@@ -106,14 +106,15 @@ EOF
'';
awesome = pkgs.writeShellScriptBin "awesome" ''
+ set -x
export XORGCONFIG=${xorgConf}
# set the LD_LIBRARY_PATH to search both the libraries needed by X, but also
# those on the host, so that the video driver has access to them if it needs
# it.
- source "${pkgs.ldUtils}"
- x_ld_lib_path="$(bin_ld_lib_path "${pkgs.xorg.xinit}/bin/xinit")"
- export LD_LIBRARY_PATH="$x_ld_lib_path":"$(host_ld_lib_path)"
+ #source "${pkgs.ldUtils}"
+ #x_ld_lib_path="$(bin_ld_lib_path "${pkgs.xorg.xinit}/bin/xinit")"
+ #export LD_LIBRARY_PATH="$x_ld_lib_path":"$(host_ld_lib_path)"
exec startx ${awesomeInner}
'';