summaryrefslogtreecommitdiff
path: root/nix/ld-utils.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/ld-utils.nix')
-rw-r--r--nix/ld-utils.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/nix/ld-utils.nix b/nix/ld-utils.nix
new file mode 100644
index 0000000..6201b63
--- /dev/null
+++ b/nix/ld-utils.nix
@@ -0,0 +1,22 @@
+# ld-utils is a collection of functions which are intended to be sourced into
+# other scripts
+pkgs: pkgs.writeShellScript "ld-utils.sh" ''
+
+# returns the colon-delimited LD_LIBRARY_PATH for host installed libraries, as
+# determined by ldconfig.
+function host_ld_lib_path {
+ ldconfig -v 2>/dev/null \
+ | grep -v ^$'\t' \
+ | cut -d':' -f1 \
+ | tr -s ':\n' ':' \
+ | head -c-1
+}
+
+# bin_ld_lib_path returns the colon-delimited LD_LIBRARY_PATH which is embedded
+# into a particular binary as its RUNPATH.
+function bin_ld_lib_path {
+ objdump -x "$1" \
+ | grep "RUNPATH" \
+ | awk '{print $2}'
+}
+''