summaryrefslogtreecommitdiff
path: root/srv/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'srv/default.nix')
-rw-r--r--srv/default.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/srv/default.nix b/srv/default.nix
index a1ce925..6bae2a8 100644
--- a/srv/default.nix
+++ b/srv/default.nix
@@ -2,6 +2,7 @@
bash,
go,
buildGoModule,
+ sqlite,
writeScript,
writeText,
stdenv,
@@ -51,13 +52,12 @@
shell = stdenv.mkDerivation {
name = "mediocre-blog-srv-shell";
- buildInputs = [ go ];
- shellHook = ''source ${init}'';
- };
+ buildInputs = [ go sqlite ];
+ shellHook = ''
+ source ${init}
- shellWithBuild = stdenv.mkDerivation {
- name = "mediocre-blog-srv-shell-with-build";
- buildInputs = [ go build ];
- shellHook = ''source ${init}'';
+ echo "Loading test data..."
+ (cd srv/src/cmd/load-test-data && go run main.go)
+ '';
};
}