summaryrefslogtreecommitdiff
path: root/srv/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'srv/default.nix')
-rw-r--r--srv/default.nix17
1 files changed, 6 insertions, 11 deletions
diff --git a/srv/default.nix b/srv/default.nix
index a5aa6af..7067e1e 100644
--- a/srv/default.nix
+++ b/srv/default.nix
@@ -52,18 +52,13 @@
shell = stdenv.mkDerivation {
name = "mediocre-blog-srv-shell";
- buildInputs = [ go build ];
- shellHook = ''
- source ${init}
- cd src
- '';
+ buildInputs = [ go ];
+ shellHook = ''source ${init}'';
};
- test = stdenv.mkDerivation {
- name = "mediocre-blog-srv-test";
- buildInputs = [ go ];
- shellHook = ''
- source ${init}
- '';
+ shellWithBuild = stdenv.mkDerivation {
+ name = "mediocre-blog-srv-shell-with-build";
+ buildInputs = [ go build ];
+ shellHook = ''source ${init}'';
};
}