summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix17
1 files changed, 1 insertions, 16 deletions
diff --git a/default.nix b/default.nix
index 8d20c38..93ba9d8 100644
--- a/default.nix
+++ b/default.nix
@@ -7,7 +7,7 @@
}) {},
baseConfig ? import ./config.nix,
- baseSkipServices ? [],
+ skipServices ? [],
}: rec {
@@ -17,12 +17,6 @@
redisListenPath = "${config.runDir}/redis";
};
- skipServices = baseSkipServices ++ (
- if baseConfig.staticProxyURL == ""
- then [ "static" ]
- else []
- );
-
static = (import ./static) { inherit pkgs; };
srv = pkgs.callPackage (import ./srv) {
@@ -59,13 +53,6 @@
numprocesses = 1
'';
- staticCircusCfg = ''
- [watcher:static]
- cmd = ${static.serve}/bin/static-serve
- numprocesses = 1
- working_dir = ./static
- '';
-
circusCfg = pkgs.writeText "mediocre-blog-circusCfg" ''
[circus]
endpoint = tcp://127.0.0.1:0
@@ -74,8 +61,6 @@
${if (!builtins.elem "srv" skipServices) then srvCircusCfg else ""}
${if (!builtins.elem "redis" skipServices) then redisCircusCfg else ""}
-
- ${if (!builtins.elem "static" skipServices) then staticCircusCfg else ""}
'';
entrypoint = pkgs.writeScript "mediocre-blog-entrypoint" ''