summaryrefslogtreecommitdiff
path: root/srv/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'srv/default.nix')
-rw-r--r--srv/default.nix8
1 files changed, 2 insertions, 6 deletions
diff --git a/srv/default.nix b/srv/default.nix
index 95f35c5..e6216b3 100644
--- a/srv/default.nix
+++ b/srv/default.nix
@@ -19,10 +19,6 @@
export MEDIOCRE_BLOG_ML_SMTP_AUTH="${config.mlSMTPAuth}"
export MEDIOCRE_BLOG_ML_PUBLIC_URL="${config.publicURL}"
- # redis
- export MEDIOCRE_BLOG_REDIS_PROTO=unix
- export MEDIOCRE_BLOG_REDIS_ADDR="${config.redisListenPath}"
-
# pow
export MEDIOCRE_BLOG_POW_SECRET="${config.powSecret}"
@@ -38,7 +34,7 @@
pname = "mediocre-blog-srv";
version = "dev";
src = ./src;
- vendorSha256 = "sha256:0kad8cyg9cd9v7m9l23jf27vkb5yfy9w89xfyrsyj7gd3q0l2yxq";
+ vendorSha256 = "sha256:1vazrrg8rs9n8x40c9r53h9qnyxw59xkp0aq7jl15fliigk6q0cr";
# disable tests
checkPhase = '''';
@@ -47,7 +43,7 @@
bin = writeScript "mediocre-blog-srv-bin" ''
#!${bash}/bin/bash
source ${init}
- exec ${build}/bin/mediocre-blog
+ exec ${build}/bin/mediocre-blog "$@"
'';
shell = stdenv.mkDerivation {