summaryrefslogtreecommitdiff
path: root/config.nix
diff options
context:
space:
mode:
authorBrian Picciano <mediocregopher@gmail.com>2022-05-19 22:44:33 -0600
committerBrian Picciano <mediocregopher@gmail.com>2022-05-19 22:44:33 -0600
commit3664286506f673737c0784b9cfd494cda1dc4618 (patch)
treeaa30b37e0d9057bf945eec0d3699404e08445b8b /config.nix
parent8da42184eb26bbd35618d81e47bcd23b6ce21adb (diff)
Actually use the auth middleware for assets routes
Diffstat (limited to 'config.nix')
-rw-r--r--config.nix25
1 files changed, 15 insertions, 10 deletions
diff --git a/config.nix b/config.nix
index 95b2b0e..1e3726c 100644
--- a/config.nix
+++ b/config.nix
@@ -1,14 +1,19 @@
{
- runDir = "/tmp/mediocre-blog/run";
- dataDir = "/tmp/mediocre-blog/data";
+ runDir = "/tmp/mediocre-blog/run";
+ dataDir = "/tmp/mediocre-blog/data";
- powSecret = "ssshhh";
- mlSMTPAddr = "";
- mlSMTPAuth = "";
- mlPublicURL = "http://localhost:4000";
- listenProto = "tcp";
- listenAddr = ":4000";
+ powSecret = "ssshhh";
+ mlSMTPAddr = "";
+ mlSMTPAuth = "";
+ mlPublicURL = "http://localhost:4000";
+ listenProto = "tcp";
+ listenAddr = ":4000";
- # If empty then a derived static directory is used
- staticProxyURL = "http://127.0.0.1:4002";
+ # If empty then a derived static directory is used
+ staticProxyURL = "http://127.0.0.1:4002";
+
+ # password is "bar". This should definitely be changed for prod.
+ apiAuthUsers = {
+ "foo" = "$2a$13$0JdWlUfHc.3XimEMpEu1cuu6RodhUvzD9l7iiAqa4YkM3mcFV5Pxi";
+ };
}