summaryrefslogtreecommitdiff
path: root/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config.nix')
-rw-r--r--config.nix25
1 files changed, 15 insertions, 10 deletions
diff --git a/config.nix b/config.nix
index 95b2b0e..1e3726c 100644
--- a/config.nix
+++ b/config.nix
@@ -1,14 +1,19 @@
{
- runDir = "/tmp/mediocre-blog/run";
- dataDir = "/tmp/mediocre-blog/data";
+ runDir = "/tmp/mediocre-blog/run";
+ dataDir = "/tmp/mediocre-blog/data";
- powSecret = "ssshhh";
- mlSMTPAddr = "";
- mlSMTPAuth = "";
- mlPublicURL = "http://localhost:4000";
- listenProto = "tcp";
- listenAddr = ":4000";
+ powSecret = "ssshhh";
+ mlSMTPAddr = "";
+ mlSMTPAuth = "";
+ mlPublicURL = "http://localhost:4000";
+ listenProto = "tcp";
+ listenAddr = ":4000";
- # If empty then a derived static directory is used
- staticProxyURL = "http://127.0.0.1:4002";
+ # If empty then a derived static directory is used
+ staticProxyURL = "http://127.0.0.1:4002";
+
+ # password is "bar". This should definitely be changed for prod.
+ apiAuthUsers = {
+ "foo" = "$2a$13$0JdWlUfHc.3XimEMpEu1cuu6RodhUvzD9l7iiAqa4YkM3mcFV5Pxi";
+ };
}